Linux: Install doesn't work
log in

Advanced search

Message boards : Number crunching : Linux: Install doesn't work

Author Message
Profile [AF>Le_Pommier] Aillas
Send message
Joined: 4 Dec 14
Posts: 10
Credit: 9,962,502
RAC: 6
Message 124 - Posted: 9 Dec 2014, 10:12:42 UTC

Hi,

I've add your project on my linux Laptop (on Ubuntu 14.10) using boinc 7.4.22 (also tested on 7.4.12)

The master file is downloaded, but when I look into the /var/lib/projects/sr../ folder, no application downloaded.

When I do an 'update' on the project, this is what I got in the Event Log:
SRbase: Update request by user
SRbase: Sending...
SRBase: Requesting new task for CPU
SRBase: Scheduler request failed: HTTP file not found
SRBase: Sending...
SRBase: Scheduler completed: Got 0 new tasks

Any idea what's wrong?

Thanks
____________


Badge Score: 8*3 + 1*4 = 28

Profile DoctorNow
Avatar
Send message
Joined: 28 Nov 14
Posts: 16
Credit: 1,407,517
RAC: 168
Message 126 - Posted: 9 Dec 2014, 13:08:58 UTC - in response to Message 124.

The master file is downloaded, but when I look into the /var/lib/projects/sr../ folder, no application downloaded.

As long as there are no WUs available, an app isn't downloaded as well as far as I know. And there is currently no work.

SRBase: Scheduler request failed: HTTP file not found
SRBase: Sending...
SRBase: Scheduler completed: Got 0 new tasks

I guess this is happening to everyone, also Windows users like me.
First try always results in an http error, second try works.
Must be some misconfiguration serverside I guess...
____________
2126*396^65889+1 and 7218*991^50722-1 are my Primes!
Proud member of BOINC@Heidelberg
My BOINC-Stats

Profile [AF>Le_Pommier] Aillas
Send message
Joined: 4 Dec 14
Posts: 10
Credit: 9,962,502
RAC: 6
Message 127 - Posted: 9 Dec 2014, 16:20:28 UTC - in response to Message 126.

Ok thanks.

So just waiting more WU.
____________


Badge Score: 8*3 + 1*4 = 28

Profile rebirther
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 2 Jan 13
Posts: 3603
Credit: 22,879,153
RAC: 0
Message 128 - Posted: 9 Dec 2014, 16:52:04 UTC - in response to Message 126.

The master file is downloaded, but when I look into the /var/lib/projects/sr../ folder, no application downloaded.

As long as there are no WUs available, an app isn't downloaded as well as far as I know. And there is currently no work.

SRBase: Scheduler request failed: HTTP file not found
SRBase: Sending...
SRBase: Scheduler completed: Got 0 new tasks

I guess this is happening to everyone, also Windows users like me.
First try always results in an http error, second try works.
Must be some misconfiguration serverside I guess...


Cant see a problem with connection. All is running fine on server and client.

DeleteNull
Volunteer tester
Send message
Joined: 29 Nov 14
Posts: 24
Credit: 2,531,637
RAC: 0
Message 129 - Posted: 9 Dec 2014, 17:10:07 UTC - in response to Message 128.

In the server access logs you can look for 404 (file not found) error codes and you will see the URL's that don't work. May be a favicon.ico or a gif is missing...

Profile rebirther
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 2 Jan 13
Posts: 3603
Credit: 22,879,153
RAC: 0
Message 130 - Posted: 9 Dec 2014, 17:47:13 UTC - in response to Message 129.

In the server access logs you can look for 404 (file not found) error codes and you will see the URL's that don't work. May be a favicon.ico or a gif is missing...


ok, I have created an empty favicon.ico and copied an image file. How about now?

DeleteNull
Volunteer tester
Send message
Joined: 29 Nov 14
Posts: 24
Credit: 2,531,637
RAC: 0
Message 131 - Posted: 9 Dec 2014, 18:00:56 UTC - in response to Message 130.
Last modified: 9 Dec 2014, 18:03:05 UTC

no cgi folder present:

09.12.2014 18:56:21 | SRBase | Requesting new tasks for CPU
09.12.2014 18:56:21 | SRBase | [http] HTTP_OP::init_post(): http://srbase.myfirewall.org/sr5/sr5_cgi/cgi
09.12.2014 18:56:21 | SRBase | [http] HTTP_OP::libcurl_exec(): ca-bundle set
09.12.2014 18:56:21 | SRBase | [http] [ID#1] Info: Connection 2192 seems to be dead!
09.12.2014 18:56:21 | SRBase | [http] [ID#1] Info: Closing connection 2192
09.12.2014 18:56:21 | SRBase | [http] [ID#1] Info: timeout on name lookup is not supported
09.12.2014 18:56:21 | SRBase | [http] [ID#1] Info: Hostname was found in DNS cache
09.12.2014 18:56:21 | SRBase | [http] [ID#1] Info: Trying 146.52.134.31...
09.12.2014 18:56:22 | SRBase | [http] [ID#1] Info: Connected to srbase.myfirewall.org (146.52.134.31) port 80 (#2193)
09.12.2014 18:56:22 | SRBase | [http] [ID#1] Sent header to server: POST /sr5/sr5_cgi/cgi HTTP/1.1
09.12.2014 18:56:22 | SRBase | [http] [ID#1] Sent header to server: User-Agent: BOINC client (windows_x86_64 7.4.32)
09.12.2014 18:56:22 | SRBase | [http] [ID#1] Sent header to server: Host: srbase.myfirewall.org
09.12.2014 18:56:22 | SRBase | [http] [ID#1] Sent header to server: Accept: */*
09.12.2014 18:56:22 | SRBase | [http] [ID#1] Sent header to server: Accept-Encoding: deflate, gzip
09.12.2014 18:56:22 | SRBase | [http] [ID#1] Sent header to server: Content-Type: application/x-www-form-urlencoded
09.12.2014 18:56:22 | SRBase | [http] [ID#1] Sent header to server: Accept-Language: de_DE
09.12.2014 18:56:22 | SRBase | [http] [ID#1] Sent header to server: Content-Length: 11755
09.12.2014 18:56:22 | SRBase | [http] [ID#1] Sent header to server: Expect: 100-continue
09.12.2014 18:56:22 | SRBase | [http] [ID#1] Sent header to server:
09.12.2014 18:56:22 | SRBase | [http] [ID#1] Received header from server: HTTP/1.1 100 Continue
09.12.2014 18:56:22 | SRBase | [http] [ID#1] Received header from server: HTTP/1.1 404 Not Found
09.12.2014 18:56:22 | SRBase | [http] [ID#1] Received header from server: Date: Tue, 09 Dec 2014 17:57:06 GMT
09.12.2014 18:56:22 | SRBase | [http] [ID#1] Received header from server: Server: Apache/2.2.22 (Ubuntu)
09.12.2014 18:56:22 | SRBase | [http] [ID#1] Received header from server: Vary: Accept-Encoding
09.12.2014 18:56:22 | SRBase | [http] [ID#1] Received header from server: Content-Encoding: gzip
09.12.2014 18:56:22 | SRBase | [http] [ID#1] Received header from server: Content-Length: 246
09.12.2014 18:56:22 | SRBase | [http] [ID#1] Received header from server: Content-Type: text/html; charset=iso-8859-1
09.12.2014 18:56:22 | SRBase | [http] [ID#1] Info: HTTP error before end of send, stop sending
09.12.2014 18:56:22 | SRBase | [http] [ID#1] Received header from server:
09.12.2014 18:56:22 | SRBase | [http] [ID#1] Info: Closing connection 2193
09.12.2014 18:56:23 | SRBase | Scheduler request failed: HTTP file not found
09.12.2014 18:56:23 | SRBase | Sending scheduler request: To fetch work.

Profile rebirther
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 2 Jan 13
Posts: 3603
Credit: 22,879,153
RAC: 0
Message 132 - Posted: 9 Dec 2014, 19:28:15 UTC

Not all getting Scheduler request failed: HTTP file not found. But its working on the second try. I will let it so.

DerekL
Avatar
Send message
Joined: 28 Dec 14
Posts: 11
Credit: 57,639
RAC: 0
Message 338 - Posted: 28 Dec 2014, 17:15:13 UTC - in response to Message 132.

I am having a similar issue using linux command line...

I can successfully add the project, but it never gets any work. I have tried

boinccmd --project http://srbase.myfirewall.org/sr5/ update
several times but when i run
boinccmd --get_tasks
it is empty.

I'm not the most experience at using boinc in linux command line, but have not had issues running other projects in the same way... any ideas??

Thanks,
Derek

Profile rebirther
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 2 Jan 13
Posts: 3603
Credit: 22,879,153
RAC: 0
Message 341 - Posted: 28 Dec 2014, 18:14:13 UTC - in response to Message 338.

I am having a similar issue using linux command line...

I can successfully add the project, but it never gets any work. I have tried
boinccmd --project http://srbase.myfirewall.org/sr5/ update
several times but when i run
boinccmd --get_tasks
it is empty.

I'm not the most experience at using boinc in linux command line, but have not had issues running other projects in the same way... any ideas??

Thanks,
Derek


I have no experiences with command line. Can you see if you are attached to the project?

DerekL
Avatar
Send message
Joined: 28 Dec 14
Posts: 11
Credit: 57,639
RAC: 0
Message 342 - Posted: 28 Dec 2014, 18:28:01 UTC - in response to Message 341.

Yes, it does show that I am attached to the project

DeleteNull
Volunteer tester
Send message
Joined: 29 Nov 14
Posts: 24
Credit: 2,531,637
RAC: 0
Message 343 - Posted: 28 Dec 2014, 18:35:30 UTC - in response to Message 342.

to update (get tasks) the project you have to use:
./boinccmd --project http://srbase.myfirewall.org/sr5/ update
(in the BOINC folder with the executables)

the --get_tasks command lists all tasks of all projects but don't update the project ;-)

DerekL
Avatar
Send message
Joined: 28 Dec 14
Posts: 11
Credit: 57,639
RAC: 0
Message 344 - Posted: 28 Dec 2014, 19:15:31 UTC - in response to Message 343.

to update (get tasks) the project you have to use:
./boinccmd --project http://srbase.myfirewall.org/sr5/ update
(in the BOINC folder with the executables)

the --get_tasks command lists all tasks of all projects but don't update the project ;-)



Right. I did update first. A few times for good measure :) Then did --get_tasks to see if anything came through.

DerekL
Avatar
Send message
Joined: 28 Dec 14
Posts: 11
Credit: 57,639
RAC: 0
Message 351 - Posted: 28 Dec 2014, 21:42:24 UTC - in response to Message 344.

Ok, good news! I got it working. Not sure exactly what I did - or if I actually did anything at all - but I'm not complaining.

Thanks for the support... lets find some primes! :)


Post to thread

Message boards : Number crunching : Linux: Install doesn't work


Main page · Your account · Message boards


Copyright © 2014-2018 BOINC Confederation / rebirther