Trial Factoring
log in

Advanced search

Message boards : Number crunching : Trial Factoring

1 · 2 · 3 · 4 . . . 20 · Next
Author Message
Profile rebirther
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 2 Jan 13
Posts: 5517
Credit: 24,182,191
RAC: 7,083
Message 5781 - Posted: 20 Mar 2020, 22:00:26 UTC
Last modified: 20 Mar 2020, 22:02:10 UTC

All the stuff was created except badges. Tomorrow I will try to start testing. Credit level of the badges cant change so you will get the badge levels faster.

The first tests are short, only some seconds. The next step is to test bigger tasks with checkpointing (every 5min).

Profile rebirther
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 2 Jan 13
Posts: 5517
Credit: 24,182,191
RAC: 7,083
Message 5784 - Posted: 21 Mar 2020, 11:18:54 UTC
Last modified: 21 Mar 2020, 11:19:01 UTC

errors summary:
(unknown error) - exit code 195 (0xc3)

Select device - Error: No platform found
ERROR: init_CL(3, 0) failed

If you seen any errors pls copy / paste from BOINC event log. If your opencl is not running install AMD SDK 2.7+

Daniel
Send message
Joined: 29 Nov 14
Posts: 6
Credit: 29,306,256
RAC: 494,659
Message 5785 - Posted: 21 Mar 2020, 11:25:55 UTC - in response to Message 5784.
Last modified: 21 Mar 2020, 11:26:23 UTC

Hi rebirther,

I just got some GPU72 v0.01 (opencl_nvidia_101) workunits and they all failed (Error while computing) after about 3 seconds.

In the event log I see a lot of messages like this ...
21/03/2020 10:16:32 PM | SRBase | Computation for task GPU72_test4_wu_380_0 finished
21/03/2020 10:16:32 PM | SRBase | Output file GPU72_test4_wu_380_0_0 for task GPU72_test4_wu_380_0 absent

Profile rebirther
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 2 Jan 13
Posts: 5517
Credit: 24,182,191
RAC: 7,083
Message 5786 - Posted: 21 Mar 2020, 11:31:11 UTC - in response to Message 5785.
Last modified: 21 Mar 2020, 11:31:27 UTC

Hi rebirther,

I just got some GPU72 v0.01 (opencl_nvidia_101) workunits and they all failed (Error while computing) after about 3 seconds.

In the event log I see a lot of messages like this ...
21/03/2020 10:16:32 PM | SRBase | Computation for task GPU72_test4_wu_380_0 finished
21/03/2020 10:16:32 PM | SRBase | Output file GPU72_test4_wu_380_0_0 for task GPU72_test4_wu_380_0 absent


Pls post this line like:

21/03/2020 12:30:51 OpenCL: AMD/ATI GPU 0: Radeon RX 5500 XT (driver version 3004.8 (PAL,LC), device version OpenCL 2.0 AMD-APP (3004.8), 8176MB, 8176MB available, 2446 GFLOPS peak)


Thx!

Daniel
Send message
Joined: 29 Nov 14
Posts: 6
Credit: 29,306,256
RAC: 494,659
Message 5787 - Posted: 21 Mar 2020, 11:33:14 UTC - in response to Message 5786.

21/03/2020 6:35:16 PM | | OpenCL: NVIDIA GPU 0: GeForce RTX 2070 (driver version 442.59, device version OpenCL 1.2 CUDA, 8192MB, 3554MB available, 8364 GFLOPS peak)
21/03/2020 6:35:16 PM | | OpenCL: NVIDIA GPU 1: GeForce GTX 1070 Ti (driver version 442.59, device version OpenCL 1.2 CUDA, 8192MB, 3554MB available, 8186 GFLOPS peak)

Sergey Kovalchuk
Send message
Joined: 27 Oct 15
Posts: 12
Credit: 5,358,484
RAC: 2
Message 5788 - Posted: 21 Mar 2020, 11:43:07 UTC

13:10:35 (948): mfakto-x64.exe exited; CPU time 0.000000
13:10:35 (948): app exit status: 0xc000007b

No DLL? VC redist or .NET ?

21.03.2020 12:58:45 | | OpenCL: AMD/ATI GPU 0: AMD Radeon HD 6790/6850/6870 series (Barts) (driver version 1800.8 (VM), device version OpenCL 1.2 AMD-APP (1800.8), 2048MB, 2015MB available, 2976 GFLOPS peak)

Profile rebirther
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 2 Jan 13
Posts: 5517
Credit: 24,182,191
RAC: 7,083
Message 5789 - Posted: 21 Mar 2020, 11:49:12 UTC - in response to Message 5788.
Last modified: 21 Mar 2020, 11:51:22 UTC

13:10:35 (948): mfakto-x64.exe exited; CPU time 0.000000
13:10:35 (948): app exit status: 0xc000007b

No DLL? VC redist or .NET ?

21.03.2020 12:58:45 | | OpenCL: AMD/ATI GPU 0: AMD Radeon HD 6790/6850/6870 series (Barts) (driver version 1800.8 (VM), device version OpenCL 1.2 AMD-APP (1800.8), 2048MB, 2015MB available, 2976 GFLOPS peak)


From the readme file you need Microsoft Visual C++ 2010 Redistributable Package for your platform and language.

I have added to the FAQ

Daniel
Send message
Joined: 29 Nov 14
Posts: 6
Credit: 29,306,256
RAC: 494,659
Message 5790 - Posted: 21 Mar 2020, 11:57:32 UTC - in response to Message 5789.

I already have Microsoft Visual C++ 2010 Redistributable installed. (both x86 and x64)
I also have these other versions installed -> 2005, 2008, 2012, 2013 and 2017

Profile rebirther
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 2 Jan 13
Posts: 5517
Credit: 24,182,191
RAC: 7,083
Message 5791 - Posted: 21 Mar 2020, 12:05:21 UTC - in response to Message 5790.
Last modified: 21 Mar 2020, 12:06:40 UTC

I already have Microsoft Visual C++ 2010 Redistributable installed. (both x86 and x64)
I also have these other versions installed -> 2005, 2008, 2012, 2013 and 2017


We could test this standalone.
download http://srbase.my-firewall.org/sr5/download/mfakto-win-v1.zip, copy this
Factor=3310968337,68,69
into the worktodo file and start the exe file.
At the moment I have less nvidia tester and it looks like only this version has only invalid results.

Stef42
Send message
Joined: 22 Dec 14
Posts: 13
Credit: 54,990,979
RAC: 6
Message 5792 - Posted: 21 Mar 2020, 12:15:00 UTC
Last modified: 21 Mar 2020, 12:19:02 UTC

I believe mfakto cannot be run on nvidia-gpu's, these use mfaktc. That it what I've been doing so far with manual assignments.

Output:
Compiletime options
Select device - Error: No platform found
ERROR: init_CL(3, 0) failed

Profile rebirther
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 2 Jan 13
Posts: 5517
Credit: 24,182,191
RAC: 7,083
Message 5793 - Posted: 21 Mar 2020, 12:17:53 UTC - in response to Message 5792.
Last modified: 21 Mar 2020, 12:18:03 UTC

I believe mfakto cannot be run on nvidia-gpu's, these use mfaktc. That it what I've been going so far with manual assignments.

Output:
Compiletime options
Select device - Error: No platform found
ERROR: init_CL(3, 0) failed


Yes I see, checked the readme file, there are only AMD cards listed, damnit

Daniel
Send message
Joined: 29 Nov 14
Posts: 6
Credit: 29,306,256
RAC: 494,659
Message 5794 - Posted: 21 Mar 2020, 12:19:14 UTC - in response to Message 5792.
Last modified: 21 Mar 2020, 12:21:33 UTC

When I run mfakto-x64.exe I get the following errors ...
Select device - Error: No platform found
ERROR: init_CL(3, 0) failed

Yes, I also noticed that in the Readme file, under "Supported GPUs", it only mentions AMD GPUs.

Profile rebirther
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 2 Jan 13
Posts: 5517
Credit: 24,182,191
RAC: 7,083
Message 5795 - Posted: 21 Mar 2020, 12:20:34 UTC - in response to Message 5794.

When I run mfakto-x64.exe I get the following errors ...
Select device - Error: No platform found
ERROR: init_CL(3, 0) failed

I noticed that in the Readme file, under "Supported GPUs", it only mentions AMD GPUs.


Thx both, I have updated the FAQ

Stef42
Send message
Joined: 22 Dec 14
Posts: 13
Credit: 54,990,979
RAC: 6
Message 5796 - Posted: 21 Mar 2020, 12:22:08 UTC - in response to Message 5793.

On NVIDIA with recent driver versions, this should be ok: https://download.mersenne.ca/mfaktc/mfaktc-0.21/mfaktc-0.21.win.cuda100.zip
(included with correct CUDA library to run out of the box)

dannyridel
Avatar
Send message
Joined: 21 Jul 19
Posts: 63
Credit: 567,207
RAC: 249
Message 5797 - Posted: 21 Mar 2020, 12:27:34 UTC - in response to Message 5781.

How can I get those tasks?

Profile rebirther
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 2 Jan 13
Posts: 5517
Credit: 24,182,191
RAC: 7,083
Message 5798 - Posted: 21 Mar 2020, 12:29:19 UTC - in response to Message 5797.

How can I get those tasks?


You must enable "Run test applications"

Profile rebirther
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 2 Jan 13
Posts: 5517
Credit: 24,182,191
RAC: 7,083
Message 5799 - Posted: 21 Mar 2020, 12:29:33 UTC - in response to Message 5796.
Last modified: 21 Mar 2020, 12:31:58 UTC

On NVIDIA with recent driver versions, this should be ok: https://download.mersenne.ca/mfaktc/mfaktc-0.21/mfaktc-0.21.win.cuda100.zip
(included with correct CUDA library to run out of the box)


Thx, I will try to setup and test. Is there a difference between all these cuda versions? Should be run on all cards.

dannyridel
Avatar
Send message
Joined: 21 Jul 19
Posts: 63
Credit: 567,207
RAC: 249
Message 5800 - Posted: 21 Mar 2020, 12:34:55 UTC - in response to Message 5798.
Last modified: 21 Mar 2020, 12:41:41 UTC

I still can't get tasks....idk why
I have enabled GPU, test apps, and get work from other apps, and GPU72.
What have I done wrong?

Stef42
Send message
Joined: 22 Dec 14
Posts: 13
Credit: 54,990,979
RAC: 6
Message 5802 - Posted: 21 Mar 2020, 12:43:08 UTC - in response to Message 5799.
Last modified: 21 Mar 2020, 12:44:05 UTC

You can read here: https://docs.nvidia.com/cuda/cuda-toolkit-release-notes/index.html

There is also a compiled version voor cuda 8.0, but these nvidia-drivers are old who still use these. FYI: Windows 10 is enforcing v430 at this point via Windows Update, so should be fine I would say.

Or perhaps enforce a minimum driver version in BOINC? Not sure if possible, I'm no developer.

Profile rebirther
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 2 Jan 13
Posts: 5517
Credit: 24,182,191
RAC: 7,083
Message 5803 - Posted: 21 Mar 2020, 12:46:14 UTC - in response to Message 5802.
Last modified: 21 Mar 2020, 12:55:30 UTC

You can read here: https://docs.nvidia.com/cuda/cuda-toolkit-release-notes/index.html

There is also a compiled version voor cuda 8.0, but these nvidia-drivers are old who still use these. FYI: Windows 10 is enforcing v430 at this point via Windows Update, so should be fine I would say.

Or perhaps enforce a minimum driver version in BOINC? Not sure if possible, I'm no developer.


I need to change 2 things:
<min_cuda_version>4020</min_cuda_version> <min_driver_version>30124</min_driver_version>


Which cuda version can run min and which driver?

I have changed to
<min_cuda_version>10000</min_cuda_version> <min_driver_version>41048</min_driver_version>


Lets see how its working.

1 · 2 · 3 · 4 . . . 20 · Next
Post to thread

Message boards : Number crunching : Trial Factoring


Main page · Your account · Message boards


Copyright © 2014-2021 BOINC Confederation / rebirther