Posts by rebirther
log in
21) Message boards : News : New TF multiGPU apps deployed (issues fixed) (Message 9671)
Posted 15 days ago by Profile rebirther
I tested with 2 Nvidias: TITAN Xp and GTX 1080. They don't work together, they each do a WU.


If you run 1 WU per GPU then all is fine
22) Message boards : Number crunching : Bases loaded (Message 9664)
Posted 18 days ago by Profile rebirther
R2
- n=7-7.5M
- runtime 7h43min-8h35min (AVX@3.8Ghz)
- 2550 credits
- Sierpinski / Riesel Base - long
- deadline 3 days
- TOP5000 primes
23) Message boards : News : New TF multiGPU apps deployed (issues fixed) (Message 9656)
Posted 19 days ago by Profile rebirther
Did you report the BOINC bug?


Not yet, can only forward to the dev, no access to git because my registration is not working and no mail so far. Git is bad, BOINC trac was better.
24) Message boards : News : New TF multiGPU apps deployed (issues fixed) (Message 9652)
Posted 19 days ago by Profile rebirther
So automatically we will get the right app?

And this will be two tasks running, one on each card, or will it be one task spread between them?


1 WU per card.
25) Message boards : News : New TF multiGPU apps deployed (issues fixed) (Message 9650)
Posted 19 days ago by Profile rebirther
status summary

2x Nvidia GPUs - windows - working
2x Nvidia GPUs - linux - working
1x Nvida + 1x AMD GPU - windows - working
2x AMD - linux - testing
2x AMD - windows - testing

A mix of 1x Nvidia + 1x AMD on windows is also working. Every plan_class is getting their own app but will only reporting cuda for both (boinc software bug)
26) Message boards : Number crunching : Bases loaded (Message 9649)
Posted 19 days ago by Profile rebirther
R672
- n=60-70k
- runtime 4min-5min (AVX@3.8Ghz)
- 18 credits
- Sierpinski / Riesel Base - short
- deadline 3 days
27) Message boards : News : New TF multiGPU apps deployed (issues fixed) (Message 9644)
Posted 20 days ago by Profile rebirther
When I put --device 0 and --device 1 in GPU1 and GPU2 respectively, it doesn't open.


Whats the content of job.xml now?
28) Message boards : Number crunching : TF work Elapsed Time kept going in an out every 4 sec. (Message 9641)
Posted 20 days ago by Profile rebirther
Exclude this project.
Why should I have to Exclude.
SRBase should exclude GTX 980 for TFs. I've seen other projects exclude work for certain projects. I got other projects that still work with the GTX 980.
Also why I'm I only getting TF from SRBase? I've got all projects selected. Are the other projects exclude for running GTX 1080 and 980s? If so then SRBase can exclude TF from GTX 980. TF still run ok on GTX 1080s.
Sorry but I'm not here to do work arounds. Not my job.


TF is only running on GPU, the rest is for CPU.
29) Message boards : News : New TF multiGPU apps deployed (issues fixed) (Message 9640)
Posted 20 days ago by Profile rebirther
[quote]<job_desc> <task> <application>mfakto.exe</application> <command_line>-d 1</command_line> </task> <unzip_input> <zipfilename>mfakto-win-v7.zip</zipfilename> </unzip_input> </job_desc>[/quote]


this was wrong, was changed in the new zipfile from -d 1 to --device 1, the same for --device 0
30) Message boards : News : New TF multiGPU apps deployed (issues fixed) (Message 9637)
Posted 20 days ago by Profile rebirther
I opened the file twice together, it works like under BOINC: GPU0 is at 100% and GPU1 is at 0


hmm, any output. I have updated the zip file due a change, whats the input of job.xml?
31) Message boards : News : New TF multiGPU apps deployed (issues fixed) (Message 9635)
Posted 20 days ago by Profile rebirther
wrapper test - standalone-windows (AMD only)

1. download zip-file
2. extract somewhere outside BOINC
3. run each wrapper file wrapper_26018_windows_x86_64.exe at the same time, in this case its for device 0 and 1
4. check the GPU usage on each card

If you want to rerun a test you need to recopy worktodo.txt because it will be deleted after a test is done
32) Message boards : News : New TF multiGPU apps deployed (issues fixed) (Message 9631)
Posted 20 days ago by Profile rebirther
The 7 minutes I said was from Boinc, which seems to race ahead with the % complete. In 15 minutes according to stderr.txt, it will be complete. We'll see if it validates. Or perhaps you can run that same task on a known good card of your own. I'd hate to think it's giving tasks back which validate but are wrong.


I dont have a good card. A standalone test is the best option to test both cards and track down the issue.
Can you make them both run the same task?

yes but not recommended. The GPU use 99% and CPU is nearly unused. Only a test can help.

I don't understand what you mean. I wanted to run the same task on both GPUs at once. If the dodgy one gives a different result, there's something up.

This is the finished task, which the server claims passed, but it can't have done if it didn't do calculations: https://srbase.my-firewall.org/sr5/result.php?resultid=141051715

Let me know how to run this test.


I will create a test later today.
33) Message boards : News : New TF multiGPU apps deployed (issues fixed) (Message 9630)
Posted 20 days ago by Profile rebirther
This could be a severe problem if there's "valid" tasks coming back which aren't. If this was happening before this update, on any machines with more than one card, can you track down suspect results and re-run them?


The result was good.

no factor for M590297503 from 2^74 to 2^75 [mfakto 0.15pre7-MGW cl_barrett15_82_gs_2]
tf(): total time spent: 1h 6m 5.398s (141.22 GHz-days / day)

ERROR: get_next_assignment(): no valid assignment found in "worktodo.txt"
2024-02-04 11:04:38 (8628): mfakto.exe exited; CPU time 10.062500
2024-02-04 11:04:38 (8628): called boinc_finish(0)
34) Message boards : News : New TF multiGPU apps deployed (issues fixed) (Message 9627)
Posted 20 days ago by Profile rebirther
The 7 minutes I said was from Boinc, which seems to race ahead with the % complete. In 15 minutes according to stderr.txt, it will be complete. We'll see if it validates. Or perhaps you can run that same task on a known good card of your own. I'd hate to think it's giving tasks back which validate but are wrong.


I dont have a good card. A standalone test is the best option to test both cards and track down the issue.
Can you make them both run the same task?


yes but not recommended. The GPU use 99% and CPU is nearly unused. Only a test can help.
35) Message boards : News : New TF multiGPU apps deployed (issues fixed) (Message 9625)
Posted 20 days ago by Profile rebirther
The 7 minutes I said was from Boinc, which seems to race ahead with the % complete. In 15 minutes according to stderr.txt, it will be complete. We'll see if it validates. Or perhaps you can run that same task on a known good card of your own. I'd hate to think it's giving tasks back which validate but are wrong.


I dont have a good card. A standalone test is the best option to test both cards and track down the issue.
36) Message boards : News : New TF multiGPU apps deployed (issues fixed) (Message 9623)
Posted 20 days ago by Profile rebirther
Well there's no heat coming from the card and MSI afterburner shows 0% usage. Boinc and the text file claim it's progressing, I assume the end result will be invalid. The one still running will be done in 7 minutes.


I cant find any useful logs. The GPU card was recognized, the selftest was successful und kernel compilation completed and run.

We can try a standalone test if the 2nd card is running. I dont trust BOINC 7.24.1 so we can do the test without BOINC.
37) Message boards : Number crunching : Bases loaded (Message 9622)
Posted 20 days ago by Profile rebirther
S504
- n=300-500k
- runtime 1h12min-2h23min (AVX@3.8Ghz)
- 300-350k = 380 credits
- 350-400k = 480 credits
- 400-450k = 600 credits
- 450-500k = 750 credits
- Sierpinski / Riesel Base - average2
- deadline 3 days
- TOP5000 primes
38) Message boards : News : New TF multiGPU apps deployed (issues fixed) (Message 9620)
Posted 20 days ago by Profile rebirther
In the meantime you can view one which started on the second card and I aborted after a few minutes:

https://srbase.my-firewall.org/sr5/result.php?resultid=141051766


Looks good so far. Perhaps the progress bar in BOINC is not working for the 2nd card. You can try to check GPUZ if the card is doing something.
39) Message boards : News : New TF multiGPU apps deployed (issues fixed) (Message 9619)
Posted 20 days ago by Profile rebirther
Not working in Windows 11 with two of AMD Radeon R9 280X cards (old things - 3GB, OpenCL 1.2). Both run and show progress in Boinc, but the second one shows 0% usage and generates no heat.

I assume the required version you speak of is the version of SRBase, which Boinc updates itself? I have 0.28 against the running tasks.

Can you post the stderr.txt of the 2nd card?

I don't have that file, or know where to find it.
I have stderrdae.txt, stderrgpudetect.txt, stdoutdae.txt, stdoutgpudetect.txt in c:\programdata\boinc.


Check your data/slots folder in BOINC, click on a WU-->properties in BOINCmanager where you can find the right slot number.
40) Message boards : News : New TF multiGPU apps deployed (issues fixed) (Message 9615)
Posted 20 days ago by Profile rebirther
Not working in Windows 11 with two of AMD Radeon R9 280X cards (old things - 3GB, OpenCL 1.2). Both run and show progress in Boinc, but the second one shows 0% usage and generates no heat.

I assume the required version you speak of is the version of SRBase, which Boinc updates itself? I have 0.28 against the running tasks.


Can you post the stderr.txt of the 2nd card?


Previous 20 · Next 20

Main page · Your account · Message boards


Copyright © 2014-2024 BOINC Confederation / rebirther